Quantcast
Download
(4 Kb)
Download
Updated: 05/24/20 06:18 PM
Addon for:
Advanced Filters.
Pictures
File Info
Compatibility:
Greymoor (6.0.5)
Harrowstorm (5.3.4)
Dragonhold (5.2.5)
Scalebreaker (5.1.5)
Elsweyr (5.0.5)
Updated:05/24/20 06:18 PM
Created:01/07/17 03:40 PM
Monthly downloads:423
Total downloads:11,899
Favorites:27
MD5:
6.0.5
Advanced Filters - FCO Item trait filter plugin  Popular! (More than 5000 hits)
Version: 2.4
by: Baertram [More]
Item trait filter plugin

This PLUGIN depends on the following ADDONs:
Advanced Filters Updated (old name: BETA)

This is a filter PLUGIN for the dynamic filters of the "Advanced Filters Updated" addon.
It is not working together with the outdated AdvancedFilters addon!
It will be able to filter your items (weapons, armor, jewelry) in your inventories by all the different item traits that the game provides.

Please use filter dropdown box of AdvancedFilters, located at the top right edge inside your inventories, to select the different filters.
Right click the filter box to invert a filter or to show all items again (reset filters).
-2.4-
Updated API
Added icons for the traits
Fixed jewelry traits not showing duplicated together with the build in AF jewelry trait filters

-2.3-
Fixed armor trait show again
Added missing jewelry traits

-2.2-
Raised API, fixed armor trait show again

-2.1-
Raised API, made compatible with actual AdvancedFilters version

-2.0-
Raised API, removed unneeded itemtype that will be buggy with next game patch 3.1

-1.9-
Sorted the entries alphabetically

-1.8-
Api raise to Homestead
Archived Files (7)
File Name
Version
Size
Uploader
Date
2.3
3kB
Baertram
05/31/19 01:35 PM
2.2
3kB
Baertram
05/27/19 09:59 PM
2.1
3kB
Baertram
08/05/18 05:45 PM
2.0
3kB
Baertram
07/16/17 01:54 PM
1.9
3kB
Baertram
04/20/17 01:29 PM
1.8
3kB
Baertram
02/06/17 02:27 PM
0.0.1
3kB
01/07/17 03:40 PM


Post A Reply Comment Options
Unread 05/24/20, 07:44 PM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 53
File comments: 415
Uploads: 11
Latest version requires library that was not updated

Last uploaded LibMotifCategories is version 2, but AdvancedFilters version 1.5.4.0 apparently requires a newer (unavailable) version.

Sorry... this is wrong addon comments.
Last edited by Shadowfen : 05/24/20 at 07:45 PM.
Report comment to moderator  
Reply With Quote
Unread 09/07/19, 03:29 PM  
M-ree

Forum posts: 1
File comments: 152
Uploads: 0
Originally Posted by Baertram
Got no intricate shield to test. Could you please send me the item link of one here? Right click it and choose To chat.
The mark the link in the chat with the mouse key pressed and use the key combination ctrl+c to copy the text. It will contain the itemlink in the clipboard then which you can paste here for me.

Edit:
Found some links from guildmates:
|H0:item:45363:308:50:0:0:0:0:0:0:0:0:0:0:0:0:3:0:0:0:10000:0|h|h
|H1:item:45363:2:26:0:0:0:0:0:0:0:0:0:0:0:0:9:0:0:0:10000:0|h|h

Well, their filter is the normal expected ITEM_TRAIT_TYPE_WEAPON_INTRICATE.
I'm not sure why they shouldn't filter correct for you. I cannot test this as I got no item..
If you have one and play on EU servers send it to @Baertram so I can test it, thanks.

Edit2:
Just read you said armor section, maybe I have messed up the filters as shields count as weapons at teh filters even if they are shown below armor at the woodworking panel. Will check this.

And the reason is: ZOs mixed them up. The shield's filtertype is ITEM_TRAIT_TYPE_WEAPON_INTRICATE but the filters at the woodworking table "armor" section try to filter for "ITEM_TRAIT_TYPE_ARMOR_INTRICATE" like it would be correct.
All other shields got the ITEM_TRAIT_TYPE_ARMOR_ filters.

See this thread: https://www.esoui.com/forums/showthr...9102#post39102

Originally Posted by M-ree
Heya

For some reason, filtering for the Intricate trait when in armor section does not show shields. Other traits work ok.

I suspect that shields might actually somehow have not the armor -> intricate but weapon -> intricate trait on them in the game, won't be the first time they were misclassed. Maybe the same goes with ornate, didn't have them to check.
Unfortunately, I am on NA server, so can't send items to test on. But yeah, that's what I mean -- ZOS has misclassed this trait for shield (happened before with them being tagged as weapons in general in some other ways, preventing Inventory Insight from finding them).

Would sending item links help to check if Ornate is classed correctly, or do you need actual items?

|H1:item:45328:2:1:0:0:0:0:0:0:0:0:0:0:0:0:8:0:0:0:10000:0|h|h
Last edited by M-ree : 09/07/19 at 04:21 PM.
Report comment to moderator  
Reply With Quote
Unread 08/31/19, 08:03 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Got no intricate shield to test. Could you please send me the item link of one here? Right click it and choose To chat.
The mark the link in the chat with the mouse key pressed and use the key combination ctrl+c to copy the text. It will contain the itemlink in the clipboard then which you can paste here for me.

Edit:
Found some links from guildmates:
|H0:item:45363:308:50:0:0:0:0:0:0:0:0:0:0:0:0:3:0:0:0:10000:0|h|h
|H1:item:45363:2:26:0:0:0:0:0:0:0:0:0:0:0:0:9:0:0:0:10000:0|h|h

Well, their filter is the normal expected ITEM_TRAIT_TYPE_WEAPON_INTRICATE.
I'm not sure why they shouldn't filter correct for you. I cannot test this as I got no item..
If you have one and play on EU servers send it to @Baertram so I can test it, thanks.

Edit2:
Just read you said armor section, maybe I have messed up the filters as shields count as weapons at teh filters even if they are shown below armor at the woodworking panel. Will check this.

And the reason is: ZOs mixed them up. The shield's filtertype is ITEM_TRAIT_TYPE_WEAPON_INTRICATE but the filters at the woodworking table "armor" section try to filter for "ITEM_TRAIT_TYPE_ARMOR_INTRICATE" like it would be correct.
All other shields got the ITEM_TRAIT_TYPE_ARMOR_ filters.

See this thread: https://www.esoui.com/forums/showthread.php?p=39102#post39102

Originally Posted by M-ree
Heya

For some reason, filtering for the Intricate trait when in armor section does not show shields. Other traits work ok.

I suspect that shields might actually somehow have not the armor -> intricate but weapon -> intricate trait on them in the game, won't be the first time they were misclassed. Maybe the same goes with ornate, didn't have them to check.
Last edited by Baertram : 09/01/19 at 03:33 PM.
Report comment to moderator  
Reply With Quote
Unread 08/31/19, 05:56 AM  
M-ree

Forum posts: 1
File comments: 152
Uploads: 0
Heya

For some reason, filtering for the Intricate trait when in armor section does not show shields. Other traits work ok.

I suspect that shields might actually somehow have not the armor -> intricate but weapon -> intricate trait on them in the game, won't be the first time they were misclassed. Maybe the same goes with ornate, didn't have them to check.
Report comment to moderator  
Reply With Quote
Unread 06/18/19, 04:28 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Hey there,

about your post:
Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I'm not able to rebuild this error so far and there are other users who told in the comments and my guilds that the addon and plugin are working fine for them.

Please logout, delete both, the plugin folder and the AdvancedFilters folder,also remove the AdvancedFilters.lua from the SavedVariables folder please!

And afterwards reinstall both from the links here (manually as Minion might **** things up sometimes):
https://www.esoui.com/downloads/info...dNameBETA.html

https://www.esoui.com/downloads/info...terplugin.html

Start the game and ONLY (during character selection screen!) enable this addon + needed libraries, and the plugin on one character. Then login with this char and tell me if the error still happens.
If so please write in detail what to do to rebuild/get this error.

If it does not happen it was most probably a wrong update or some other addon causing it and you need to check how to rebuild th error, having which addons and plugins enabled please.

Many thanks. Hope this will fix it for you though!

Baertram



Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Report comment to moderator  
Reply With Quote
Unread 06/03/19, 05:29 PM  
fgoron2000

Forum posts: 0
File comments: 115
Uploads: 0
Originally Posted by Baertram
Not that easy, there is changed a lot. I hope I'm able to get the error too, so I can test it.

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
I've been offline for a few days so I only had a chance to try this addon today, but the new version worked fine for me, the menus were listed at the crafting stations as expected, and I got no lua errors.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 05:11 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Not that easy, there is changed a lot. I hope I'm able to get the error too, so I can test it.

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 02:44 AM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 28
File comments: 322
Uploads: 0
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
Last edited by SteveCampsOut : 06/01/19 at 02:45 AM.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 01:25 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Last edited by Baertram : 06/01/19 at 01:33 AM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 06:39 PM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 28
File comments: 322
Uploads: 0
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Last edited by SteveCampsOut : 05/31/19 at 06:44 PM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 01:34 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 06:20 PM  
fgoron2000

Forum posts: 0
File comments: 115
Uploads: 0
Originally Posted by Baertram
Okay, sorry then. I'll need to dig in further into the addon code.
Fixing the missing jewelry traits as well I guess is a good idea.
But I'm on vacations soon so don't expect anything in the next weeks

Originally Posted by fgoron2000
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
understood, thanks again, and let me know if i can provide any info for you when you're back from vacay


I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 12:29 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Okay, sorry then. I'll need to dig in further into the addon code.
Fixing the missing jewelry traits as well I guess is a good idea.
But I'm on vacations soon so don't expect anything in the next weeks

Originally Posted by fgoron2000
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 09:58 PM  
fgoron2000

Forum posts: 0
File comments: 115
Uploads: 0
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 09:44 AM  
fgoron2000

Forum posts: 0
File comments: 115
Uploads: 0
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: