Quantcast
Download
(7 Kb)
Download
Updated: 03/25/20 03:49 AM
Pictures
File Info
Compatibility:
Harrowstorm (5.3.4)
Updated:03/25/20 03:49 AM
Created:06/14/14 02:23 PM
Monthly downloads:23,359
Total downloads:209,655
Favorites:317
MD5:
LibHarvensAddonsSettings  Popular! (More than 5000 hits)
Version: 1.7.5
by: Harven [More]
Description
With this addon you can create and add your addon settings to the common settings page. The functionality is similar to great Seerah's LibAddonMenu addon but it's written from scratch. The settings page can be found in Settings->Addons menu. When you open that menu you will see sorted addons names. Chosen addon setting will appear after clicking addon name. Main features:
- only one addon settings are visible at a time,
- no control is created when you define your addon settings to avoid "Too many anchors processed" error,
- controls are created when you select an addon,
- when you select another addon the controls are reused, so the number of controls will stay at decent level

Usage
Edit your addon manifest file and add following line:
Code:
## DependsOn: LibHarvensAddonSettings
Then take a look at this example addon:
lua: HarvensAddonSettingsExample.lua
manifest: HarvensAddonSettingsExample.txt

Version 1.7.5
- editcontrol: new parameters textType and maxChars (thanks to Scootworks),
- editcontrol: save value if you leave the control without pressing enter (thanks to Scootworks),
- bye bye LibStub

Version 1.7.4
- Fixed controls reanchoring to the top of the panel when used together with LAM

Version 1.7.3
- Changed the type of this addon to library,
- Made LibStub optional,
- Compatibility fixes to 100029 API

Version 1.0.7.2
- Lots of changes since last update ;)

Version 1.0.4
- Added support for default values and "Defaults" button handler,
- Settings controls can be enabled/disabled,
- Done some code refactoring,
- Support for optional "options" table as second parameter to LibHarvensAddonSettings:AddAddon(), see example addon.

Version 1.0.3
- Fixed exception caused by adding more than one addon with the same name,
- Colors are removed from addons names.

Version 1.0.2
- Made some fixes suggested by Garkin.

Version 1.0.1
- Removed whole .xml file because when used in more than one addon, virtual controls were redefined and ESO doesn't like it. Insted the controls are created inside the lua code (still using control pools).
Optional Files (0)


Archived Files (8)
File Name
Version
Size
Uploader
Date
1.7.4
6kB
Harven
11/01/19 08:32 AM
1.7.3
6kB
Harven
10/31/19 03:42 PM
1.0.7.2
7kB
Harven
02/27/19 03:56 AM
1.0.4
7kB
Harven
06/19/14 03:39 PM
1.0.3
6kB
Harven
06/17/14 10:37 AM
1.0.2
6kB
Harven
06/15/14 10:51 AM
1.0.1
6kB
Harven
06/14/14 03:58 PM
1.0.0
6kB
Harven
06/14/14 02:23 PM


Post A Reply Comment Options
Unread 08/25/20, 03:29 PM  
Nukluk
 
Nukluk's Avatar

Forum posts: 0
File comments: 21
Uploads: 0
LibHarvensAddonSettings Breaking Votan's Mini Map

EDIT 8/26/2020: I found/solved my issue but want to keep this post here in case it's helpful for others.

Causing the Issue:
The AwesomeGuildStore addon caused the issue I outlined below. Once I disabled (only) this addon, and re-enabled everything else, my mini map glitching problem was resolved.


NOT Causing the Issue:
Votan's Mini Map and LibHarvensAddonsSettings were not the root cause of my mini map going all wonky.

IGNORE THIS GRAY Text:
I am posting the following in Votan's Mini Map comments area. Posting here too in hopes someone can fix this issue:

Something is definitely wrong since the last patch. I can't use Votan's Mini Map anymore either. I've loaded the latest versions of that addon's dependencies, including the "LibHarvensAddonSettings".


Issue Symptoms:
  • Votan's Minimap 'glitches' several times per second, trying to render the map of the zone/place I'm in, and the entire Glenumbra map (I'm not in Glenumbra). It mostly stays on the Glenumbra map, but has 1/10th second glitches to the maps where I'm at. Even after the troubleshooting below, the mini map glitching remains.
Previous Troubleshooting:
  • I've removed every addon that has "LibHarvensAddonsSettings", except Votan's Minimap, and restarted the game.
  • In addition, I also removed every Harven's and Votan's addon, except Votan's Minimap, and restarted the game.

Edit: Also, ESO is showing LibHarvensAddonsSettings is out of date.
__________________


Last edited by Nukluk : 08/26/20 at 06:54 AM.
Report comment to moderator  
Reply With Quote
Unread 07/31/20, 05:03 PM  
prtpj

Forum posts: 2
File comments: 49
Uploads: 0
Re: Possible workaround for error & disabled Esc menu

Didnt work for me

Because this bug on this lib I cant use anymore vontan's minimap

Originally Posted by Sorrieah
Disclaimer: I am not an addon author or someone who knows anything about Lua, I just read the previous posts here and figured I'd consolidate what I learned from them for people looking for answers.

If you're getting an error like the one in previous posts, followed by the Esc menu not working, try the following:
  1. Backup your addons folder!
  2. Run a search in your ESO live Addons folder for "LibHarvensAddonSettings". Delete any versions packaged with a different addon. One known addon to have this issue is the Harven's Subtitles addon, and Harven's Thieves Trove Markers might also (but I don't have it to check). The subtitles addon also has LibStub packaged with it, that you may as well delete if you have it installed separately.
  3. In the *.lua files for each addon you deleted, the following line:
    Code:
    local LibHarvensAddonSettings = LibStub("LibHarvensAddonSettings-1.0")
  4. Change the part that reads
    Code:
    LibStub("LibHarvensAddonSettings-1.0")
    to
    Code:
    LibHarvensAddonSettings
  5. Try running ESO and see if it worked...

This worked for me, but I only had Harven's Subtitles to test with. Hopefully it works for you.
Report comment to moderator  
Reply With Quote
Unread 07/17/20, 12:42 PM  
GottaSlay

Forum posts: 0
File comments: 18
Uploads: 0
Update the addon please

<3
Report comment to moderator  
Reply With Quote
Unread 06/30/20, 01:40 AM  
patdrum

Forum posts: 0
File comments: 4
Uploads: 0
NEEDS A UPDATE

this addon needs an update since the chapter came out the addon settings wont show up. now its messing with items in my inventory. please update.
Report comment to moderator  
Reply With Quote
Unread 06/27/20, 03:12 PM  
prtpj

Forum posts: 2
File comments: 49
Uploads: 0
Re: Possible workaround for error & disabled Esc menu

I will try this, but before just wanna to tell, the addons you mentioned (Subtitles and thieves trove) I havent any of them AND I have the issue with ESC and all other menus arent working.
I did a downgrade to the version 1.7.4 of this lib and almost everything is working. The only two addons which arent working for me is: Votan's Lore Library Search and Harven's AS to LAM adapter. Both ask for the new version of LibHarvensAddonsSettings

Originally Posted by Sorrieah
Disclaimer: I am not an addon author or someone who knows anything about Lua, I just read the previous posts here and figured I'd consolidate what I learned from them for people looking for answers.

If you're getting an error like the one in previous posts, followed by the Esc menu not working, try the following:
  1. Backup your addons folder!
  2. Run a search in your ESO live Addons folder for "LibHarvensAddonSettings". Delete any versions packaged with a different addon. One known addon to have this issue is the Harven's Subtitles addon, and Harven's Thieves Trove Markers might also (but I don't have it to check). The subtitles addon also has LibStub packaged with it, that you may as well delete if you have it installed separately.
  3. In the *.lua files for each addon you deleted, the following line:
    Code:
    local LibHarvensAddonSettings = LibStub("LibHarvensAddonSettings-1.0")
  4. Change the part that reads
    Code:
    LibStub("LibHarvensAddonSettings-1.0")
    to
    Code:
    LibHarvensAddonSettings
  5. Try running ESO and see if it worked...

This worked for me, but I only had Harven's Subtitles to test with. Hopefully it works for you.
Report comment to moderator  
Reply With Quote
Unread 06/27/20, 02:46 AM  
Sorrieah

Forum posts: 0
File comments: 11
Uploads: 0
Lightbulb Possible workaround for error & disabled Esc menu

Disclaimer: I am not an addon author or someone who knows anything about Lua, I just read the previous posts here and figured I'd consolidate what I learned from them for people looking for answers.

If you're getting an error like the one in previous posts, followed by the Esc menu not working, try the following:
  1. Backup your addons folder!
  2. Run a search in your ESO live Addons folder for "LibHarvensAddonSettings". Delete any versions packaged with a different addon. One known addon to have this issue is the Harven's Subtitles addon, and Harven's Thieves Trove Markers might also (but I don't have it to check). The subtitles addon also has LibStub packaged with it, that you may as well delete if you have it installed separately.
  3. In the *.lua files for each addon you deleted, the following line:
    Code:
    local LibHarvensAddonSettings = LibStub("LibHarvensAddonSettings-1.0")
  4. Change the part that reads
    Code:
    LibStub("LibHarvensAddonSettings-1.0")
    to
    Code:
    LibHarvensAddonSettings
  5. Try running ESO and see if it worked...

This worked for me, but I only had Harven's Subtitles to test with. Hopefully it works for you.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 01:58 PM  
Helldir
 
Helldir's Avatar

Forum posts: 5
File comments: 20
Uploads: 0
Re: Re: Re: Duplicate name?

Originally Posted by Trollwut
Okay, played around and for me it was this addon: https://www.esoui.com/downloads/info...Subtitles.html
Thanks. Disabling Harven's Subtitles also did it for me. Hope he opdates it soon.
__________________

So many corpses. So little time.
Report comment to moderator  
Reply With Quote
Unread 06/01/20, 10:30 AM  
tlbracken

Forum posts: 0
File comments: 6
Uploads: 0
Yeah I just installed the older versions of the addons that got 'updated'.
Report comment to moderator  
Reply With Quote
Unread 05/31/20, 04:08 PM  
Trollwut
 
Trollwut's Avatar

Forum posts: 6
File comments: 23
Uploads: 0
Re: Re: Duplicate name?

Okay, played around and for me it was this addon: https://www.esoui.com/downloads/info...Subtitles.html
Report comment to moderator  
Reply With Quote
Unread 05/31/20, 03:57 PM  
Trollwut
 
Trollwut's Avatar

Forum posts: 6
File comments: 23
Uploads: 0
Re: Duplicate name?

Originally Posted by MadDragon
Was prompted to install LibHarvensAddOnSettins recently. It wasn't installed until today, but Harven's AS to LAM was working.

After installation, I get the following errors, and ESC is then completely disabled.
tried deleting saved variables.
about to try uninstallation and see if that repairs things.


First error screen:
Failed to create control 'LibHarvensAddonSettingsContainer'. Duplicate name.

When "dismissed", it's followed by:
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:866: attempt to index a nil value
stack traceback:
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:866: in function 'LibHarvensAddonSettings:CreateAddonSettingsPanel'
|caaaaaa<Locals> self = [table:1]{version = 7.2, ST_LABEL = 7, ST_SECTION = 8, ST_COLOR = 5, panelID = 102, ST_BUTTON = 6, ST_DROPDOWN = 4, ST_CHECKBOX = 1, ST_SLIDER = 2, ST_EDIT = 3} </Locals>|r
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:924: in function 'LibHarvensAddonSettings:Initialize'
|caaaaaa<Locals> self = [table:1] </Locals>|r
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:940: in function 'OptionsWindowFragmentStateChange'
|caaaaaa<Locals> oldState = "hidden", newState = "showing" </Locals>|r
EsoUI/Libraries/Utility/ZO_CallbackObject.lua:116: in function 'ZO_CallbackObject:FireCallbacks'
|caaaaaa<Locals> self = [table:2]{wasShownInGamepadPreferredMode = F, restoresHUDSceneToggleGameMenu = F, disallowEvaluateTransitionCompleteCount = 1, restoresHUDSceneToggleUIMode = F, name = "gameMenuInGame", fireCallbackDepth = 1, wasRequestedToShowInGamepadPreferredMode = F, state = "showing"}, eventName = "StateChange", registry = [table:3]{}, callbackInfoIndex = 2, callbackInfo = [table:4]{3 = F}, callback = user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:930, deleted = F </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:276: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:2], newState = "showing", oldState = "hidden", name = "gameMenuInGame" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:200: in function 'ZO_SceneManager_Base:ShowScene'
|caaaaaa<Locals> self = [table:5]{exitUIModeOnChatFocusLost = F, hudUISceneHidesAutomatically = T, fireCallbackDepth = 0, remoteSceneSequenceNumber = 9, initialized = F, hudSceneName = "hud", hudUISceneName = "hudui", numRemoteTopLevelShown = 0, numTopLevelShown = 0}, scene = [table:2], sequenceNumber = 9 </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:290: in function 'ZO_SceneManager_Leader:ShowScene'
|caaaaaa<Locals> self = [table:5], scene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:373: in function 'ZO_SceneManager_Leader:OnSceneStateHidden'
|caaaaaa<Locals> self = [table:5], scene = [table:6]{wasShownInGamepadPreferredMode = F, restoresHUDSceneToggleGameMenu = F, disallowEvaluateTransitionCompleteCount = 1, restoresHUDSceneToggleUIMode = F, name = "hud", fireCallbackDepth = 0, wasRequestedToShowInGamepadPreferredMode = F, state = "hidden"}, currentNextScene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:274: in function 'ZO_SceneManager_Base:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:320: in function 'ZO_SceneManager_Leader:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:354: in function 'ZO_IngameSceneManager:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:277: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:6], newState = "hidden", oldState = "hiding", name = "hud" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:426: in function 'ZO_Scene:OnTransitionComplete'
|caaaaaa<Locals> self = [table:6], nextState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:421: in function 'ZO_SceneetermineIfTransitionIsComplete'
|caaaaaa<Locals> self = [table:6], nextState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:333: in function 'ZO_Scene:RefreshFragments'
|caaaaaa<Locals> self = [table:6], asAResultOfSceneStateChange = T </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:286: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:6], newState = "hiding", oldState = "shown", name = "hud", AS_A_RESULT_OF_SCENE_STATE_CHANGE = T </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:208: in function 'ZO_SceneManager_Base:HideScene'
|caaaaaa<Locals> self = [table:5], scene = [table:6], sequenceNumber = 8 </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:294: in function 'ZO_SceneManager_Leader:HideScene'
|caaaaaa<Locals> self = [table:5], scene = [table:6] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:258: in function 'ZO_SceneManager_Leader:Show'
|caaaaaa<Locals> self = [table:5], sceneName = "gameMenuInGame", nextSceneClearsSceneStack = T, numScenesNextScenePops = 0, currentScene = [table:6], nextScene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:224: in function 'ZO_SceneManager_Base:Toggle'
|caaaaaa<Locals> self = [table:5], sceneName = "gameMenuInGame" </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:590: in function 'ZO_IngameSceneManager:OnToggleGameMenuBinding'
|caaaaaa<Locals> self = [table:5], SHOW_BASE_SCENE = T, topLevelHidden = F, baseSceneShown = F </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:619: in function 'ZO_SceneManager_ToggleGameMenuBinding'
:1: in function '(main chunk)'
|caaaaaa<Locals> keybind = "TOGGLE_SYSTEM" </Locals>|r

(ignore the |caaaaaa before <Locals> and the |r after, seems to be an artifact of cut/paste, doesn't appear on the screen when I read it)
I got the same exact error. Unfortunately I have to turn off the complete library, which renders addons unuseable.

Is there a fix for that?
Report comment to moderator  
Reply With Quote
Unread 05/29/20, 10:29 PM  
Shaminar

Forum posts: 0
File comments: 1
Uploads: 0
I think I found the addon that is causing the trouble.

It's Harven's Thief Troves markers.
Report comment to moderator  
Reply With Quote
Unread 05/24/20, 06:06 PM  
MadDragon

Forum posts: 3
File comments: 40
Uploads: 0
Duplicate name?

Was prompted to install LibHarvensAddOnSettins recently. It wasn't installed until today, but Harven's AS to LAM was working.

After installation, I get the following errors, and ESC is then completely disabled.
tried deleting saved variables.
about to try uninstallation and see if that repairs things.


First error screen:
Failed to create control 'LibHarvensAddonSettingsContainer'. Duplicate name.

When "dismissed", it's followed by:
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:866: attempt to index a nil value
stack traceback:
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:866: in function 'LibHarvensAddonSettings:CreateAddonSettingsPanel'
|caaaaaa<Locals> self = [table:1]{version = 7.2, ST_LABEL = 7, ST_SECTION = 8, ST_COLOR = 5, panelID = 102, ST_BUTTON = 6, ST_DROPDOWN = 4, ST_CHECKBOX = 1, ST_SLIDER = 2, ST_EDIT = 3} </Locals>|r
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:924: in function 'LibHarvensAddonSettings:Initialize'
|caaaaaa<Locals> self = [table:1] </Locals>|r
user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:940: in function 'OptionsWindowFragmentStateChange'
|caaaaaa<Locals> oldState = "hidden", newState = "showing" </Locals>|r
EsoUI/Libraries/Utility/ZO_CallbackObject.lua:116: in function 'ZO_CallbackObject:FireCallbacks'
|caaaaaa<Locals> self = [table:2]{wasShownInGamepadPreferredMode = F, restoresHUDSceneToggleGameMenu = F, disallowEvaluateTransitionCompleteCount = 1, restoresHUDSceneToggleUIMode = F, name = "gameMenuInGame", fireCallbackDepth = 1, wasRequestedToShowInGamepadPreferredMode = F, state = "showing"}, eventName = "StateChange", registry = [table:3]{}, callbackInfoIndex = 2, callbackInfo = [table:4]{3 = F}, callback = user:/AddOns/HarvensTraitAndStyle/LHAS/LibHarvensAddonSettings.lua:930, deleted = F </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:276: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:2], newState = "showing", oldState = "hidden", name = "gameMenuInGame" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:200: in function 'ZO_SceneManager_Base:ShowScene'
|caaaaaa<Locals> self = [table:5]{exitUIModeOnChatFocusLost = F, hudUISceneHidesAutomatically = T, fireCallbackDepth = 0, remoteSceneSequenceNumber = 9, initialized = F, hudSceneName = "hud", hudUISceneName = "hudui", numRemoteTopLevelShown = 0, numTopLevelShown = 0}, scene = [table:2], sequenceNumber = 9 </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:290: in function 'ZO_SceneManager_Leader:ShowScene'
|caaaaaa<Locals> self = [table:5], scene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:373: in function 'ZO_SceneManager_Leader:OnSceneStateHidden'
|caaaaaa<Locals> self = [table:5], scene = [table:6]{wasShownInGamepadPreferredMode = F, restoresHUDSceneToggleGameMenu = F, disallowEvaluateTransitionCompleteCount = 1, restoresHUDSceneToggleUIMode = F, name = "hud", fireCallbackDepth = 0, wasRequestedToShowInGamepadPreferredMode = F, state = "hidden"}, currentNextScene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:274: in function 'ZO_SceneManager_Base:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:320: in function 'ZO_SceneManager_Leader:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:354: in function 'ZO_IngameSceneManager:OnSceneStateChange'
|caaaaaa<Locals> self = [table:5], scene = [table:6], oldState = "hiding", newState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:277: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:6], newState = "hidden", oldState = "hiding", name = "hud" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:426: in function 'ZO_Scene:OnTransitionComplete'
|caaaaaa<Locals> self = [table:6], nextState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:421: in function 'ZO_SceneetermineIfTransitionIsComplete'
|caaaaaa<Locals> self = [table:6], nextState = "hidden" </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:333: in function 'ZO_Scene:RefreshFragments'
|caaaaaa<Locals> self = [table:6], asAResultOfSceneStateChange = T </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:286: in function 'ZO_Scene:SetState'
|caaaaaa<Locals> self = [table:6], newState = "hiding", oldState = "shown", name = "hud", AS_A_RESULT_OF_SCENE_STATE_CHANGE = T </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:208: in function 'ZO_SceneManager_Base:HideScene'
|caaaaaa<Locals> self = [table:5], scene = [table:6], sequenceNumber = 8 </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:294: in function 'ZO_SceneManager_Leader:HideScene'
|caaaaaa<Locals> self = [table:5], scene = [table:6] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:258: in function 'ZO_SceneManager_Leader:Show'
|caaaaaa<Locals> self = [table:5], sceneName = "gameMenuInGame", nextSceneClearsSceneStack = T, numScenesNextScenePops = 0, currentScene = [table:6], nextScene = [table:2] </Locals>|r
EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:224: in function 'ZO_SceneManager_Base:Toggle'
|caaaaaa<Locals> self = [table:5], sceneName = "gameMenuInGame" </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:590: in function 'ZO_IngameSceneManager:OnToggleGameMenuBinding'
|caaaaaa<Locals> self = [table:5], SHOW_BASE_SCENE = T, topLevelHidden = F, baseSceneShown = F </Locals>|r
EsoUI/Ingame/Scenes/IngameSceneManager.lua:619: in function 'ZO_SceneManager_ToggleGameMenuBinding'
:1: in function '(main chunk)'
|caaaaaa<Locals> keybind = "TOGGLE_SYSTEM" </Locals>|r

(ignore the |caaaaaa before <Locals> and the |r after, seems to be an artifact of cut/paste, doesn't appear on the screen when I read it)
Report comment to moderator  
Reply With Quote
Unread 05/14/20, 06:45 AM  
deljason
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 69
Uploads: 1
Originally Posted by votan
Originally Posted by deljason
I'm trying to use an addon that requires this Lib but I get an error and the settings->Add-Ons menu just says settings are not currently available.

The error I get is "Cannot fin d a library Instance" for this Lib. I have verified I do not have any other versions of this Lib hiding in any of the addons folders.

Any idea how to fix this?
@deljason Replace LibStub("LibHarvensAddonSettings") with LibHarvensAddonSettings.
And tell me the name of the addon, please.
Ill try that and see. It is this addon: https://www.esoui.com/downloads/info...tion.html#info

Its an older one that came bundled with an older libStub and LibHarvensAddonSettings. I removed them both but that wasnt able to fix it.

I found the "LibStub" line you mentioned and changed it to:
Local LibHarvensAddonSettings = LibHarvensAddonSettings

That appears to have fixed the error and made the addon settings menu work.
Report comment to moderator  
Reply With Quote
Unread 05/14/20, 06:35 AM  
votan
 
votan's Avatar
AddOn Author - Click to view AddOns

Forum posts: 519
File comments: 1356
Uploads: 35
Originally Posted by deljason
I'm trying to use an addon that requires this Lib but I get an error and the settings->Add-Ons menu just says settings are not currently available.

The error I get is "Cannot fin d a library Instance" for this Lib. I have verified I do not have any other versions of this Lib hiding in any of the addons folders.

Any idea how to fix this?
@deljason Replace LibStub("LibHarvensAddonSettings") with LibHarvensAddonSettings.
And tell me the name of the addon, please.
__________________
@votan73 (EU - megaserver)
Report comment to moderator  
Reply With Quote
Unread 05/14/20, 05:46 AM  
deljason
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 69
Uploads: 1
I'm trying to use an addon that requires this Lib but I get an error and the settings->Add-Ons menu just says settings are not currently available.

The error I get is "Cannot fin d a library Instance" for this Lib. I have verified I do not have any other versions of this Lib hiding in any of the addons folders.

Any idea how to fix this?
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: