Quantcast
Download
(12 Kb)
Download
Updated: 03/02/20 09:02 PM
Pictures
File Info
Compatibility:
Harrowstorm (5.3.4)
Updated:03/02/20 09:02 PM
Created:10/26/19 05:58 AM
Monthly downloads:72
Total downloads:784
Favorites:4
MD5:
AllCraft
Version: 0.935Alpha
by: MethosFrost [More]
AllCraft Will Replace several of my often used Crafting Addons and allow for order taking and direct mail. Currently in pre-alpha uploading for access assistance.

**Only Accountwide settings currently**

Required Lib Addons:
LibStub (Will remove when I get LibAddonMenu-2.0 to function properly without it)
LibAddonMenu-2.0
LibSets


Currently available options:

Mass Deconstruct
  • TTC and MM cutoff limit to prevent deconstruction over a minimum sell price
  • Seperate max deconstruct item level options based on character extraction level
  • Auto-refine recursively as needed
  • Refine set type for deconstruct

Smart Settings
  • Auto Deconstruct or refine availability based on Max level and max extraction level
  • Exclude intricate if Character is at max level
  • Exclude crafted if DolgubonsLazyWritCreator (temporary) has writs listed
Corrected issue with LibAddonMenu-2.0 but requires libStub again for now.

API Update.
Added selectable set types for deconstruct method.
Dynamic Menu (work in progress)
Optional Files (0)


Archived Files (4)
File Name
Version
Size
Uploader
Date
0.930Alpha
12kB
MethosFrost
02/29/20 03:51 AM
0.910Alpha
10kB
MethosFrost
10/30/19 07:50 PM
0.910Alpha
10kB
MethosFrost
10/28/19 09:17 PM
0.9Alpha
9kB
MethosFrost
10/26/19 05:58 AM


Post A Reply Comment Options
Unread 03/10/20, 07:42 PM  
MethosFrost
AddOn Author - Click to view AddOns

Forum posts: 5
File comments: 11
Uploads: 1
Originally Posted by Baertram
Lua Code:
  1. local menu = LibAddonMenu2
  2. if not menu and LibStub then menu = LibStub("LibAddonMenu-2.0") end

This will work properly for LAm2 without LibStub and with LibStub.
Thanks! I will do that for the update where I fix the "Smart Settings" to function again!



Side Note:
I think I've seen people using LAM without LibStub but When I made the simple changes to the code it broke. I'll need to look deeper at what they are doing differently as I'm still learning LUA and ESO API in my limited spare time.
Report comment to moderator  
Reply With Quote
Unread 03/05/20, 04:25 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
Your description says:
Code:
LibStub (Will remove when I get LibAddonMenu-2.0 to function properly without it)
What is not working properly at LAM2 for you, without LibStub?

The dependency to LibStub is within LAM2 so your addon is not depending on it and shouldn't be named as a dependency here.
Users installing LAM2 will automatically install LibStub as long as it is included.
Once it is removed there it will be automatically changed in all addons.

So please change your code in AllCraft_DeconMenu.lua from this:
Code:
local menu = LibStub("LibAddonMenu-2.0")
to this at least to support the non LibStub version of LAM2 properly:
Lua Code:
  1. local menu = LibAddonMenu2
  2. if not menu and LibStub then menu = LibStub("LibAddonMenu-2.0") end

This will work properly for LAm2 without LibStub and with LibStub.
Last edited by Baertram : 03/05/20 at 04:26 AM.
Report comment to moderator  
Reply With Quote
Unread 03/02/20, 08:43 PM  
MethosFrost
AddOn Author - Click to view AddOns

Forum posts: 5
File comments: 11
Uploads: 1
Originally Posted by Akopian Atrebates
Received the following error:

user:/AddOns/AllCraft/AllCraftMenuBuilder.lua:131: operator # is not supported for # nil
stack traceback:
user:/AddOns/AllCraft/AllCraftMenuBuilder.lua:131: in function 'ACLoadMenu'
|caaaaaa<Locals> t = [table:1]{KeepCertMats = T, Deconstruct_Set_Type_Daily_Reward = T, DeconstructCrafted = F, Deconstruct_Set_Type_Cyrodiil = T, DeconstructOrnate = F, Jewlery_Extraction_Max = 4, Deconstruct_Set_Type_Crafted = F, Use_Bank = T, Enchanting_Extraction_Max = 4, Deconstruct_Set_Type_Dungeon = T, Debug_Mode_On = F, Deconstruct_Set_Items = F, Account_Wide_Settings = T, Deconstruct_Set_Type_Overland = T, Deconstruct_Set_Type_Special = T, Enchanting_Extraction_Not_Max = 3, MMMax = 1000, Blacksmithing_Extraction_Max = 4, Jewlery_Extraction_Not_Max = 3, Woodworking_Extraction_Not_Max = 3, Woodworking_Extraction_Max = 4, Deconstruct_Set_Type_Monster = F, DeconstructBound = F, Blacksmithing_Extraction_Not_Max = 3, TTCMax = 1000, Smart_Settings_On = T, Deconstruct_Set_Type_Trial = F, Deconstruct_Set_Type_Imperial_City = T, Deconstruct_Set_Type_Arena = T, Clothing_Extraction_Max = 4, Clothing_Extraction_Not_Max = 3, version = 1, DeconstructIntricate = T, PricingOn = T, Deconstruct_Set_Type_Battleground = T, List_Before_Deconstruct = T}, setting = [table:2]{}, menu = [table:3]{}, setTypeSM = [table:4]{}, qualitySM = [table:5]{name = "Item Quality Deconstruction Op...", type = "submenu"}, Enchanting = [table:6]{} </Locals>|r
user:/AddOns/AllCraft/AllCraft_DeconMenu.lua:248: in function 'AllCraftDeconMenu'
|caaaaaa<Locals> LAM = [table:7]{panelId = 101}, set = [table:2], panel = [table:8]{name = "AllCraft: Deconstructor", version = "0.910", slashCommand = "/acd", author = "Methos_Frost", type = "panel", displayName = "AllCraft: Deconstructor"}, options = [table:9]{} </Locals>|r
user:/AddOns/AllCraft/AllCraft.lua:77: in function 'AddonInitialize'
|caaaaaa<Locals> event = 65536, addonName = "AllCraft" </Locals>|r
I found the cause will be updating in the next couple of hours unless something else breaks in testing. I plain forgot to test as an upgrade.
Report comment to moderator  
Reply With Quote
Unread 03/02/20, 08:39 PM  
MethosFrost
AddOn Author - Click to view AddOns

Forum posts: 5
File comments: 11
Uploads: 1
Originally Posted by Baertram
You should add the needed dependencies to the addon description.
LibAddonMenu-2.0
LibSets
Will Add it, Thanks!
Report comment to moderator  
Reply With Quote
Unread 03/01/20, 02:28 AM  
Akopian Atrebates

Forum posts: 5
File comments: 161
Uploads: 0
Received the following error:

user:/AddOns/AllCraft/AllCraftMenuBuilder.lua:131: operator # is not supported for # nil
stack traceback:
user:/AddOns/AllCraft/AllCraftMenuBuilder.lua:131: in function 'ACLoadMenu'
|caaaaaa<Locals> t = [table:1]{KeepCertMats = T, Deconstruct_Set_Type_Daily_Reward = T, DeconstructCrafted = F, Deconstruct_Set_Type_Cyrodiil = T, DeconstructOrnate = F, Jewlery_Extraction_Max = 4, Deconstruct_Set_Type_Crafted = F, Use_Bank = T, Enchanting_Extraction_Max = 4, Deconstruct_Set_Type_Dungeon = T, Debug_Mode_On = F, Deconstruct_Set_Items = F, Account_Wide_Settings = T, Deconstruct_Set_Type_Overland = T, Deconstruct_Set_Type_Special = T, Enchanting_Extraction_Not_Max = 3, MMMax = 1000, Blacksmithing_Extraction_Max = 4, Jewlery_Extraction_Not_Max = 3, Woodworking_Extraction_Not_Max = 3, Woodworking_Extraction_Max = 4, Deconstruct_Set_Type_Monster = F, DeconstructBound = F, Blacksmithing_Extraction_Not_Max = 3, TTCMax = 1000, Smart_Settings_On = T, Deconstruct_Set_Type_Trial = F, Deconstruct_Set_Type_Imperial_City = T, Deconstruct_Set_Type_Arena = T, Clothing_Extraction_Max = 4, Clothing_Extraction_Not_Max = 3, version = 1, DeconstructIntricate = T, PricingOn = T, Deconstruct_Set_Type_Battleground = T, List_Before_Deconstruct = T}, setting = [table:2]{}, menu = [table:3]{}, setTypeSM = [table:4]{}, qualitySM = [table:5]{name = "Item Quality Deconstruction Op...", type = "submenu"}, Enchanting = [table:6]{} </Locals>|r
user:/AddOns/AllCraft/AllCraft_DeconMenu.lua:248: in function 'AllCraftDeconMenu'
|caaaaaa<Locals> LAM = [table:7]{panelId = 101}, set = [table:2], panel = [table:8]{name = "AllCraft: Deconstructor", version = "0.910", slashCommand = "/acd", author = "Methos_Frost", type = "panel", displayName = "AllCraft: Deconstructor"}, options = [table:9]{} </Locals>|r
user:/AddOns/AllCraft/AllCraft.lua:77: in function 'AddonInitialize'
|caaaaaa<Locals> event = 65536, addonName = "AllCraft" </Locals>|r
Report comment to moderator  
Reply With Quote
Unread 02/29/20, 04:28 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2964
File comments: 3581
Uploads: 62
You should add the needed dependencies to the addon description.
LibAddonMenu-2.0
LibSets
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: