Quantcast LibMediaProvider update - ESOUI
Thread Tools Display Modes
03/02/20, 12:29 PM   #1
Smirake
Join Date: Mar 2020
Posts: 2
Exclamation LibMediaProvider update

LibMediaprovider hasn't been updated for Harrowstorm, ANY adds that rely on this library WILL NOT work as the recent update has perminently disabled this addon. Any addon providers must find a work around or their idea will never work.
  Reply With Quote
03/02/20, 02:33 PM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,875
ehrm, just enable the "Disable out of date addons" checkbox ingame in the addon manager eh voila: It works

And please ALWAYS enable this checkbox after major updates as the game will disabale it but it is a nonsense function which does nto say anyhting about "is an addon working or not".
it just compares the game's APIversion number to a number "hardcoded" into the addons/libraries txt file. If they differ the game says "It is outdated". That#s all.

You can find about 100000 threads and post about this already so please just enbale the checkbox OR if you do not believe me and want to fgight your own windmills: update LibMediaProvider.txt and change ## AddOnVersin: to 100030

You'll notice it works again all of sudden without having updated the addon/librray. Wow!

Last edited by Baertram : 03/02/20 at 02:36 PM.
  Reply With Quote
03/02/20, 02:50 PM   #3
Smirake
Join Date: Mar 2020
Posts: 2
Unfortunately, that function doesn't work right on my end. I click that and then reload the ui and it doesn't take effect, set it at start up and the game just sets it to whatever.
  Reply With Quote
03/03/20, 12:34 AM   #4
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,875
Logout.
Search for AddonSettings.txt on your harddrives.
if you find multiple: The one with the most up2date change date and time!

The fodler where it is in: Add it to your whitelist/exclusion lists of AntiVirus and Firewall programs installed (WIndows Defender e.g.).

Should be something like:
c:\users\Smirake\documents\Elder scrolls online\live

And if this does not work I already wrote in my first post how you can change the ## APIVersion: tag in the txt files of the addons.
Just write it like this into the file:

## APIVersion: 100030

Next major update it will be ## APIVersion: 100031 than, and so on
  Reply With Quote
03/03/20, 10:36 AM   #5
ArtOfShred
 
ArtOfShred's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2016
Posts: 97
I'll update LMP later tonight when I get off work, slipped my mind to do so when Harrowstorm came out.

EDIT: Done https://www.esoui.com/downloads/info...ider.html#info

Last edited by ArtOfShred : 03/03/20 at 06:09 PM.
  Reply With Quote

ESOUI » General Discussion » Tech Chat » LibMediaProvider update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off